C++ خطوات تحديد إصدار المترجم في برنامج CodeBlocks

إذا كنت تريد التعامل مع كود خاص بإصدار مترجم محدد, أو تريد تجربة أشياء متعلقة بإصدار مترجم محدد فلا بد لك من تحديد إصدار المترجم الذي تريده أن يفسر الكود الذي كتبته للحاسوب حتى لا يظهر لك أخطاء عند محاولة تشغيل الكود.

كمثال بسيط, إذا أردت استخدام الكلمة auto في الكود, يجب أن تحدد لبرنامج CodeBlocks أنك تتعامل مع إصدار المترجم [-std=c++11] لأن الإصدارات الأقدم من هذا الإصدار لم تكن الكلمة auto قد أضيفت فيها بعد و هذا يعني أنها تعتبر شيء غير معروف بالنسبة للإصدارات القديمة و يؤدي لظهور مشاكل في الكود عند تشغيله.


الآن لتحديد رقم الإصدار الذي تتعامل معه, يمكنك اتباع هذه الخطوات البسيطة:

1. أنقر على Settings, ثم Compiler كالتالي.


2. قم بوضع علامة صح على إصدار المترجم (Compiler) الذي تريده, ثم أنقر على OK كالتالي.

الدورات

أدوات مساعدة

أقسام الموقع

دورات
مقالات كتب مشاريع أسئلة